The LetterPress WordPress plugin before 2.4.0 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)

Project Subscriptions

No data.

Advisories

No advisories yet.

Fixes

Solution

No solution given by the vendor.


Workaround

No workaround given by the vendor.

History

Thu, 29 Oct 2026 07:45:00 +0000

Type Values Removed Values Added
Weaknesses CWE-79

Thu, 29 Oct 2026 06:15:00 +0000

Type Values Removed Values Added
Description The LetterPress WordPress plugin before 2.4.0 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Title LetterPress < 2.4.0 - Admin+ Stored XSS
References

Projects

Sign in to view the affected projects.

cve-icon MITRE

Status: PUBLISHED

Assigner: WPScan

Published:

Updated: 2026-10-29T06:00:23.500Z

Reserved: 2024-04-10T14:12:39.458Z

Link: CVE-2024-3586

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Received

Published: 2026-10-29T06:17:16.020

Modified: 2026-10-29T06:17:16.020

Link: CVE-2024-3586

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-29T07:30:14Z

Weaknesses